Frågor och svar

Tillbaka
Sökord:  

PHP 7.x, hur fungerar det hos Domänshop?

Det här avsnittet av våra frågor och svar innehåller information avsedd för både icke-tekniska och tekniska användare och utvecklare.

PHP 7.4 är standarden för alla Webhotell Medium eller större skapade från 20 augusti 2020.

PHP 7.3 var standarden för alla Webhotels Medium eller större skapade från 5 februari 2019 till 20 augusti 2020.

PHP 7.2 var standarden för alla Webhotels Medium eller större som skapades från slutet av maj 2018 till 5 februari 2019.

Vi erbjuder följande PHP-versioner:

  • 7.3 (stöds till hösten 2021)
  • 7.4 (stöds till hösten 2022)

Om du upplever problem som du tror beror på våra inställningar eller brister på våra servrar, kontrollera först att du har programvara som hanterar PHP-versionen du använder, och att tipsen nedan inte hjälper, innan du eventuellt kontaktar kundtjänst.

Översikt


När kommer PHP 7.xi att fungera normalt?

PHP 7 är i normal drift.

Vad svarar denna SOS-punkt?

Den här sidan försöker täcka några av de saker som vi tror att det kommer att finnas frågor om, eller som vi har blivit tillfrågade om. Vi uppdaterar detta kontinuerligt.

Vilka är skillnaderna mellan den gamla och den nya webbservrarna?

Operativsystemet på alla nya webbservrar kör Debian 9 Stretch, en uppdatering från Debian 8 Jessie.

Vad är skillnaden mellan PHP 7-versionerna?

Det finns inga större skillnader mellan de olika PHP 7-versionerna hos Domänshop. Se här för detaljerad information om ändringar mellan de olika versionerna:

PHP-konfigurationen för PHP 7.x är i stort sett densamma som 5.6. Vi uppmärksammar särskilt följande:

  • Om ditt CMS (t.ex. Drupal, Joomla!, WordPress) inte har uppdaterats på flera år, eller din egen php.ini , kan du få ett felmeddelande om "mysql-anslutning", "mysql-drivrutin" eller "mysqli-drivrutin". Detta beror på att programvaran inte är kompatibel med PHP 7. Uppgradera till den aktuella versionen.
  • Stöd för IonCube Loader kan aktiveras i kontrollpanelen på webbhotellet. Det kommer då inte att vara möjligt att använda din egen php.ini . Detta är att föredra framför att fortsätta använda dina egna php.ini filer och dina egna tillägg.
  • Zend Guard Loader är officiellt utfasad från och med PHP 7.0 .

Vad fungerar inte på PHP 7.x webbservrar?

Den stora majoriteten av programvara som fungerar bra i PHP 5.6 kommer också att köras i PHP 7. Kontrollera med din programvaruleverantör om du är osäker på om din programvara stöder PHP 7.

Du kan få ett felmeddelande om MySQL, "mysqli" etc. om du har gammal php.ini måste denna fil tas bort.

För anpassad kod, se PHP-dokumentationen för vilka ändringar inte är bakåtkompatibla med PHP 7.

Om du använder dina egna moduler eller tillägg i PHP 5.6 måste dessa förmodligen uppgraderas för att vara kompatibla med nyare PHP (7.x). Detta gäller (men inte uteslutande) IonCube Loader . Stöd för IonCube Loader ska helst aktiveras via kontrollpanelen för webbhotellet.

Kan jag växla mellan de olika PHP-versionerna?

Ja, du kan växla mellan de olika versionerna. Observera att det kan ta upp till 20 minuter för ändringar av PHP-versionen att exekveras.

När vi meddelar att vi inte längre stöder en version kommer det inte längre att vara möjligt att välja den versionen.

Kan jag testa/använda PHP 7 på shell.domeneshop.no/via SSH?

Ja. Du kan använda php-shell.domeneshop.no . Denna skalserver erbjuder automatiskt samma PHP-version som den du har valt för ditt webbhotell.

Hur länge kommer du att stödja de olika PHP-versionerna?

Vi kommer att stödja de olika versionerna ungefär så länge som PHP erbjuder säkerhetsuppdateringar , men kommer att börja utfasas innan säkerhetsuppdateringarna slutar.

Vi avbröt PHP 5.6 och PHP 7.0 den 12 december 2018, avbröt PHP 7.1 den 1 december 2019 och avbröt PHP 7.2 den 2 november 2020.

För andra versioner, följ länken och planera uppgraderingar i god tid. Våra planer kan ändras tillsammans med PHP:s säkerhetssupportplaner.

Mitt PHP-program fungerar inte, vad kan vara fel?

Se Hur kan jag se PHP-fel/felsöka PHP-kod? för hjälp med felsökning av PHP.

Om du använder Wordpress , aktivera felloggning enligt beskrivningen ovan. I många fall kommer felmeddelandena som visas att hänvisa till ett Wordpress-plugin som orsakar problem. Denna tillägg kan sedan inaktiveras genom att ta bort eller byta namn på plugin-mappen via FTP. Se här för en mer detaljerad förklaring av hur detta går till.

Kända problem efter uppgradering

Om du upplever problem efter uppgraderingen, kontrollera den här sökordslistan för vanliga problem och lösningar.

"Din PHP-installation verkar sakna MySQL-tillägget som krävs av WordPress."

Din WordPress är för gammal, uppgradera till den senaste versionen. Minsta version som stöder PHP 7.3 och högre är WordPress 5.0.

"Fel i anslutningen till databasen"

Ta bort gamla php.ini .

"Mysqli-tillägget saknas"

Ta bort gamla php.ini .

Sidan visas inte/felkod 500

Joomla!/WordPress: se vår snabbguide för att felsöka Joomla!- och WordPress-problem
Annan PHP-programvara: se vår allmänna PHP-felsökningsguide

Silverstripe fungerar inte

Ta bort silverstripe-cache mappen på ditt webbhotell.

SME fungerar inte

Uppgradera SMF till 2.0.18 eller senare, eller ersätt SMF med en annan produkt som stöder PHP 7.4 och senare.

Norska tecken visas som frågetecken eller inte alls

default_charset definieras i PHP som UTF-8 . Om du har innehåll i Latin-1 (ISO 8859-1) eller andra gammaldags teckenuppsättningar kommer dessa att visas felaktigt. Du kan antingen konvertera innehållet till UTF-8 eller ställa in default_charset="" i .user.ini

mcrypt fungerar inte

mcrypt är inte tillgängligt för PHP 7.2 och högre, uppgradera programvaran till en version som stöder PHP 7.4 och högre, och som använder OpenSSL eller Sodium istället för Mcrypt.

omkodning fungerar inte

recode finns inte för PHP 7.4 och senare, uppgradera programvaran till en version som stöder PHP 7.4 och senare och använd andra moduler.

Own ErrorDocument fungerar inte för PHP-filer , men fungerar för andra filer

Alla filnamn som slutar på .php hanteras av uWSGI, Apaches ErrorDocument kommer aldrig att aktiveras för sådana filer.

Perl fick en säkerhetsuppdatering (debian.org) som inte tillåter direkt require på filer utan att ange sökväg.

Använd local::lib och andra aktuella Perl-mekanismer för att skapa dina egna Perl-bibliotek, eller manipulera @INC direkt om du vet hur.

Hur ändrar jag PHP-version?

  1. Logga in på kontrollpanelen på www.domanshop.se
  2. Klicka på "Mina domäner"
  3. Klicka på relevant domän
  4. Klicka på fliken "Webbhotell" högst upp på sidan
  5. Klicka på "Visa/Ändra" på raden med PHP
  6. Välj sedan önskad PHP-version.
  7. Tryck på "Ändra" för att spara.

Observera att det kan ta upp till 20 minuter innan ändringen träder i kraft.

Se även:

© 2022 Domeneshop AS · Om oss · Villkor · Dataskydd